Home  |  Contents 

Microcontroller and PC projects
  Forum Index : Microcontroller and PC projects         Section
Subject Topic: Armmite - STM32H7: Developments Post ReplyPost New Topic
<< Prev Page of 12 Next >>
Author
Message << Prev Topic | Next Topic >>
matherp
Guru
Guru


Joined: 11 December 2012
Location: United Kingdom
Online Status: Offline
Posts: 2164
Posted: 11 July 2018 at 7:58pm | IP Logged Quote matherp

Attached is version 5.04.24

2018-07-12_013125_Armmite.zip

This fixes IR which is now tested and working. The DISTANCE command is also checked and working. It also introduces an additional parameter for the SSD1963 which controls the speed of writing. Usage should be obvious from the listing below. GUI TEST LCDPANEL is also used to give comparative speeds

The three drivers are:
SSD1963_5 ' eight bit driver
Full speed 117 circles per second
Throttled speed 64 circles per second

SSD1963_5_16 'sixteen bit driver
Full speed 298 circles per second
Throttled speed 175 circles per second

SSD1963_5_buff ' sixteen bit driver with a full in-memory image.
Full speed 394 circles per second
Throttled speed 206 circles per second

The latter uses a big chunk of user memory but can significantly reduce screen artifacts when updating and will be considerably faster for things like drawing circles and triangles





Edited by matherp on 12 July 2018 at 2:44am



Back to Top View matherp's Profile Search for other posts by matherp
 
cdeagle
Senior Member
Senior Member


Joined: 22 June 2014
Location: United States
Online Status: Offline
Posts: 179
Posted: 12 July 2018 at 8:09am | IP Logged Quote cdeagle

Is there a way to turn off the check for the SD card?

Thanks for all the great work everybody

Back to Top View cdeagle's Profile Search for other posts by cdeagle
 
matherp
Guru
Guru


Joined: 11 December 2012
Location: United Kingdom
Online Status: Offline
Posts: 2164
Posted: 12 July 2018 at 6:15pm | IP Logged Quote matherp

Quote:
Is there a way to turn off the check for the SD card?


Don't understand the question or the intent
Back to Top View matherp's Profile Search for other posts by matherp
 
TassyJim
Guru
Guru


Joined: 07 August 2011
Location: Australia
Online Status: Offline
Posts: 2544
Posted: 12 July 2018 at 6:21pm | IP Logged Quote TassyJim

matherp wrote:

Jim: You might want to try changing the resistors on the MicroSD I/F card, Mine are 1K which seems unnecessarily high. 100ohm would be fine or even 0ohm.

Thanks to all for your continued testing



The resistors on my module are all 10k from signal line to 3.3V
They all test OK.
There are no series resistors.
I expect I have a sh*tty contact somewhere. It's a long wait for a replacement.

Jim

__________________
It all started with the ZX81....
VK7JH
http://www.c-com.com.au/MMedit.htm
Back to Top View TassyJim's Profile Search for other posts by TassyJim Visit TassyJim's Homepage
 
TrevorH
Regular Member
Regular Member


Joined: 06 April 2018
Location: United Kingdom
Online Status: Offline
Posts: 53
Posted: 12 July 2018 at 9:20pm | IP Logged Quote TrevorH

Hi Peter,

I have tried using the new speed related drivers with no luck.
I have moved on to the 7 inch just to see if it might have been my 5" display causing the problem, again no change.

Here is a screen shot of some "text" tests, quality from my Samsung Tab not the best.



'Testing different text colours on different colour backgrounds for the Armmite
'Using 7 inch ssd1963 TFT with OPTION LCDPANEL SSD1963_7_16,RL


cls
text 20,20,"White on Black",,2,,rgb(white),rgb(black):text 220,20,"White on Blue",,2,,rgb(white),rgb(blue)
text 420,20,"White on Red",,2,,rgb(white),rgb(red):text 600,20,"White on Green",,2,,rgb(white),rgb(green)

Text 20,45,"Red on Black",,2,,Rgb(red):text 220,45,"Red on Blue",,2,,rgb(red),rgb(blue)
text 420,45,"Blue on Red",,2,,rgb(blue),rgb(red):text 600,45,"Red on Green",,2,,rgb(red),rgb(green)

text 20,70,"Green on Black",,2,,rgb(green):text 220,70,"Green on Blue",,2,,rgb(green),rgb(blue)
text 420,70,"Green on Red",,2,,rgb(green),rgb(red):text 600,70,"White on Blue",,2,,rgb(white),rgb(blue)

text 20,95,"Blue on Black",,2,,rgb(blue):text 220,95,"Black on Blue",,2,,rgb(black),rgb(blue)
text 420,95,"Blue on Red",,2,,rgb(blue),rgb(red):text 600,95,"Blue on Green",,2,,rgb(blue),rgb(green)

text 20,120,"Cyan on Black",,2,,rgb(cyan),rgb(black):text 220,120,"Cyan on Blue",,2,,rgb(cyan),rgb(blue)
text 420,120,"Cyan on Red",,2,,rgb(cyan),rgb(red)

text 20,145,"Magenta on Black",,2,,rgb(magenta):text 220,145,"Magenta on Blue",,2,,rgb(magenta),rgb(blue)
text 600,145,"Magenta on Green",,2,,rgb(magenta),rgb(green)

text 20,170,"Yellow on Black",,2,,rgb(yellow):text 220,170,"Yellow on Blue",,2,,rgb(yellow),rgb(blue)
text 420,170,"Yellow on Red",,2,,rgb(yellow),rgb(red)

text 20,195,"Brown on Black",,2,,rgb(brown):text 220,195,"Brown on Blue",,2,,rgb(brown),rgb(blue)

text 20,220,"Grey on Black",,2,,rgb(gray):text 220,220,"Grey on Blue",,2,,rgb(gray),rgb(blue)
text 420,220,"Grey on Red",,2,,rgb(gray),rgb(red):text 600,220,"Grey on Green",,2,,rgb(gray),rgb(green)

text 20,245,"Black on White",,2,,rgb(black),rgb(white):text 420,245,"Black on Red",,2,,rgb(black),rgb(red)
text 220,245,"Black on Blue",,2,,rgb(black),rgb(blue):text 600,245,"Black on Green",,2,,rgb(black),rgb(green)


The lower left below "Grey on Black" is "Black on White" and resembles top left "White on Black", not clear on photo.

It's weird certain colours react differently.

Trevor.
Back to Top View TrevorH's Profile Search for other posts by TrevorH
 
cdeagle
Senior Member
Senior Member


Joined: 22 June 2014
Location: United States
Online Status: Offline
Posts: 179
Posted: 12 July 2018 at 10:44pm | IP Logged Quote cdeagle

When I try to download a MMBASIC program using MMEdit I get the following error message,

XMODEM RECEIVE "TEMP.BAS"

Error: SD card not found

I do not currently have an SD card attached to the H743ZI. Hence my question about bypassing the check for an SD card.

I have ordered an SD breakout, so it's really not a big deal.
Back to Top View cdeagle's Profile Search for other posts by cdeagle
 
matherp
Guru
Guru


Joined: 11 December 2012
Location: United Kingdom
Online Status: Offline
Posts: 2164
Posted: 12 July 2018 at 11:30pm | IP Logged Quote matherp

Quote:
"TEMP.BAS"


This is the syntax for downloading a file to the SD card

Just use

"XMODEM RECEIVE" to load into memory


Back to Top View matherp's Profile Search for other posts by matherp
 
cdeagle
Senior Member
Senior Member


Joined: 22 June 2014
Location: United States
Online Status: Offline
Posts: 179
Posted: 12 July 2018 at 11:43pm | IP Logged Quote cdeagle

The XMODEM RECEIVE "TEMP.BAS" message is displayed after the load and run command is issued from within MMEdit.

I'm not sure how to do what you suggest. Thanks Peter
Back to Top View cdeagle's Profile Search for other posts by cdeagle
 
TrevorH
Regular Member
Regular Member


Joined: 06 April 2018
Location: United Kingdom
Online Status: Offline
Posts: 53
Posted: 12 July 2018 at 11:44pm | IP Logged Quote TrevorH

Just a thought, am I the only one getting this problem with the Armmite & TFT?

Anyone??

Trevor.
Back to Top View TrevorH's Profile Search for other posts by TrevorH
 
matherp
Guru
Guru


Joined: 11 December 2012
Location: United Kingdom
Online Status: Offline
Posts: 2164
Posted: 12 July 2018 at 11:50pm | IP Logged Quote matherp

Quote:
The XMODEM RECEIVE "TEMP.BAS" message is displayed after the load and run command is issued from within MMEdit.


Sounds like you have the syntax drop down in MMEdit incorrectly set. Choose "Micromite_X_V5.3"
Back to Top View matherp's Profile Search for other posts by matherp
 
cdeagle
Senior Member
Senior Member


Joined: 22 June 2014
Location: United States
Online Status: Offline
Posts: 179
Posted: 13 July 2018 at 12:14am | IP Logged Quote cdeagle

Thanks Peter.

Syntax change worked. I had an older version of MMEdit.

I will be testing some of my astronomy programs on the H743ZI.
Back to Top View cdeagle's Profile Search for other posts by cdeagle
 
matherp
Guru
Guru


Joined: 11 December 2012
Location: United Kingdom
Online Status: Offline
Posts: 2164
Posted: 13 July 2018 at 12:16am | IP Logged Quote matherp

Quote:
I will be testing some of my astronomy programs on the H743ZI.


Excellent

I always use your solar eclipse code to test my various versions for accuracy.
Back to Top View matherp's Profile Search for other posts by matherp
 


<< Prev Page of 12 Next >>
In the news...
 
Post ReplyPost New Topic
Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.8
Copyright ©2001-2004 Web Wiz Guide

This page was generated in 0.1250 seconds.
Privacy Policy     Process times : 0, 0, 0, 0.12