About time the ArmmiteH7 got some TLC: V5.07.01 betas


Author Message
HardingJohn

Regular Member

Joined: 28/07/2017
Location: Australia
Posts: 63
Posted: 06:22am 15 Jan 2022      

Definitely come to the conclusion that the only way I might be able to program the STM32H743ZI ver V 480Mhz with the new faster version 5.07.01b0 and get it run is to use the STlink V3 programmer.  Nothing else has worked. Tried the ArmmiteH7 first, powered down and then the 5.07.01b0 and this did not work either. Everything loads fine, just won't run.

What is interesting is that I have no trouble getting the STM32H743ZI ver V 480Mhz to run using the slower 5.05.11 firmware. I can of course get the 5.07.01b0 firmware to run on the older ver Y 400Mhz chip.

It does not appear to be possible to use the USB port of the STM32H743ZI ver V to load the firmware in the same manner as can be done with the STM32H743II 176pin chip.

Is there something going on with the new faster firmware that prevents an STlink V2 from programming the new ver V 480Mhz chip?

Hoping for some help?
Should I order a STlink V3 programmer?