MMEdit V5.2


Author Message
Turbo46

Guru

Joined: 24/12/2017
Location: Australia
Posts: 1598
Posted: 05:06am 26 Aug 2023      

Hi Jim, The keyword "Image" was not being capitalised and highlighted for the PicomiteVGA so I added it to both of the the .tkn files (in alphabetical order) and that fixed it.

Also something is still confusing me about the syntax. I have two programs loaded into MMEdit the first is a DOS one and the second is a PicomiteVGA one. With the PicomiteVGA tab open I select PicomiteVGA as the syntax that shows in the status line at the bottom. Close MMEdit an then reopen it. The correct syntax shows at the bottom but the syntax in the menu dropdown has DOS selected.

As a test, I closed the DOS program tab and loaded it again in the second tab. Selected the PicomiteVGA program tab set the syntax to PicomiteVGA shut down and restart. Still the same. It seems that it always starts with the DOS syntax highlighted in the syntax dropdown.

Is this expected? Should I just find something important to worry about?

Bill