Home Built CNC Project


Author Message
Bryan1

Guru

Joined: 22/02/2006
Location: Australia
Posts: 1224
Posted: 12:47am 01 Jan 2024      

Well saw the new year in trying to get the steppers to move with no luck, first tried PWM and when I hit run there was a noise coming from from the DM556 but no movement. So the tried servo with the same result.   The green LED was on with all 3 of the DM556's so and no red LED lit at all thru the night.

Now for reference I did pullup each data line with the 5 volt rail on the CMM2 and connected ground from the CMM2 to the board.

Then just tried pin(12) = 1
pause
pin(12) = 0

Now using my fluke 865 on scope mode only saw 3.5 volts and no hertz, toggled the direction and enable and did see the voltages change so that did prove the CMM2 does have life outside.

So I do think the voltage is too low to drive the DM556 direct and I will need to make up a board and use a higher DC voltage so when the PWM running the 1/2 average voltage is above 5 volts.

Anyway my scope should be here later in the week then I can have a real time look at what really is going on.

Cheers Bryan
Edited 2024-01-01 11:13 by Bryan1