
PicoMiteBT -- BLE Console for Pico 2 W

PicoMiteBT is a build variant of PicoMite MMBasic that replaces the USB CDC console with a Bluetooth Low Energy
serial link. Instead of plugging a USB cable in for the BASIC prompt, you connect wirelessly from a phone, laptop, or
desktop computer.

Internally it advertises a Nordic UART Service (NUS) over BLE -- the same GATT profile used by Adafruit Bluefruit,
Nordic dev kits, and most other BLE-serial peripherals -- so the device works out of the box with any BLE-NUS-aware
terminal app, and with a small Python bridge for OSes that don't have one (Windows, Linux).

What you need

• A Raspberry Pi Pico 2 W (the pico2_w board -- Pico 2 alone does
  not have a wireless chip).
• The PICOBTRP2350 firmware variant -- built by BuildPicoMite.bat
  alongside the standard set, or directly with CMake:   cmake -DCOMPILE=PICOBTRP2350 -G "NMake Makefiles" ..
• A BLE-capable host: any modern phone, almost any Windows 10+ laptop,
  any Linux machine with BlueZ 5.x.
• For Windows / Linux terminal use: Python 3.8+ with bleak
  (pip install bleak) and a terminal program. The repo ships   ble_bridge.py for the BLE -> TCP forwarding.

Device name

On startup the firmware builds a name from the last four hex characters of the chip's unique board ID, e.g.
PicoMite-77BA. This name appears in every scan, and is what you point your tools at.

You can confirm the name on your specific board by scanning from a phone the first time.

Phone (Android / iOS)

Phones are the easiest path -- no bridge, no Python.

Android:

1. Install Serial Bluetooth Terminal (Kai Morich) from the Play
   Store.
2. Open the app, tap the menu -> Devices -> Bluetooth LE.
3. Tap the scan icon. Pick PicoMite-XXXX from the list.
4. The app will prompt you to pair -- accept (no PIN, "Just Works"
   pairing).
5. Back in the terminal view, you should see the MMBasic banner. Press
   Enter for the > prompt.

iOS:

1. Install Bluefruit Connect (Adafruit) -- free.
2. Connect to the PicoMite-XXXX device.
3. Use the UART tab. iOS handles the pairing transparently.

Subsequent re-connects don't require re-pairing -- the phone remembers the bond.
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Windows (Tera Term)

Windows doesn't expose a BLE serial port as a COM port, so we run a small Python bridge that converts BLE NUS into
a TCP socket, then point Tera Term at that socket.

One-off setup

1. Pair the device once via Windows Settings:
• Settings -> Bluetooth & devices -> Add device -> Bluetooth
• Pick PicoMite-XXXX from the list, wait for "Paired".
• Windows will show it as "Not connected" -- that is expected; the
     Settings UI only handles pairing, not the GATT data stream.

2. Install Python and bleak:
   pip install bleak

3. Configure Tera Term (one-off; Setup -> Save setup... persists
   these):
• Setup -> Terminal -> Local echo: OFF
• Setup -> Terminal -> Local Edit Mode: OFF
• Setup -> Terminal -> Terminal ID: VT100 (or VT-AT386)

Every session

1. Start the bridge:
   python ble_bridge.py PicoMite-XXXX

   The bridge scans, connects, then listens on TCP port 5555:    `    [TCP] listening on telnet://127.0.0.1:5555    [BLE]
target device: 'PicoMite-XXXX'    [BLE] scanning for 'PicoMite-XXXX'...    [BLE] found 28:CD:C1:..., connecting...    [BLE]
connected, subscribing to TX notifications    `

2. In Tera Term: File -> New connection -> TCP/IP
• Host: 127.0.0.1
• Service: Telnet
• TCP port#: 5555

3. Hit Enter, you get the MMBasic prompt.

Bridge options

python ble_bridge.py                       # default device name "Pico-RP2350"

python ble_bridge.py PicoMite-77BA         # specific device

python ble_bridge.py PicoMite-77BA --port 6000

Auto-reconnect

If you reboot the Pico (OPTION CPU_SPEED, error trap, manual reset) the bridge automatically reconnects within ~10
seconds without dropping the Tera Term TCP session. You'll see this in the bridge console:
[BLE] disconnected

[BLE] scanning for 'PicoMite-77BA'...

[BLE] found ..., connecting...

[BLE] connected, subscribing to TX notifications
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Tera Term stays put; data flow pauses then resumes.

Linux (PuTTY)

Same architecture as Windows: pair once, then run ble_bridge.py and point a terminal at TCP 127.0.0.1:5555.

One-off setup

1. Install bleak and PuTTY:
   pip install bleak

   sudo apt install putty            # or: dnf install putty

2. Pair the device once via bluetoothctl:
   $ bluetoothctl

   [bluetooth]# scan on

   [NEW] Device 28:CD:C1:FF:B7:8D PicoMite-77BA

   [bluetooth]# pair 28:CD:C1:FF:B7:8D

   [agent] Confirm passkey ... (yes/no): yes

   [bluetooth]# trust 28:CD:C1:FF:B7:8D

   [bluetooth]# scan off

   [bluetooth]# exit

   The bond is stored in /var/lib/bluetooth/<adapter>/<peer-mac>/.

3. User permissions -- your user must be allowed to use BLE:
   sudo usermod -aG bluetooth $USER

   Log out and back in. (Some distros handle this via polkit; if you    see DBusError: Not authorized from bleak, this is
what to fix.)

Every session

1. Start the bridge:
   python ble_bridge.py PicoMite-77BA

2. Open PuTTY:
• Session -> Connection type: Raw
• Host Name: 127.0.0.1
• Port: 5555
• Open

   (Raw is preferred over Telnet on Linux PuTTY because PuTTY's Telnet    mode and our IAC negotiation can have
subtle interactions; Raw just    passes bytes through. The bridge's Telnet handshake doesn't hurt    anything in Raw
mode either -- PuTTY ignores the IAC bytes.)

3. Set vt100 emulation: in the PuTTY config tree, Terminal -> Keyboard
   leave defaults; **Window -> Translation -> Remote character set:    UTF-8; Window -> Colours -> ANSI Colour:** OK.

4. Save the session (give it a name, click "Save") so you don't have to
   re-enter the settings.
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Pairing model and key storage

PicoMiteBT uses BLE Just Works pairing -- no PIN, no MITM protection. Pairing is automatic; the user doesn't have to
type or confirm anything beyond the OS-level "Pair?" dialog.

After pairing, the long-term key (LTK) is stored on the Pico inside the PicoMite Option struct (Option.bt_tlv[] -- a 2 KB
area split into two 1 KB banks). It survives reboot and OPTION RESET -- only a full factory reset / MagicKey change
wipes it.

Up to 4 hosts can be paired at the same time. The Pico keeps a key for each. So you can pair the same Pico with your
desk PC, laptop, and phone, and reconnect from whichever one is convenient without re-pairing.

When the table is full and a 5th host pairs, btstack evicts the oldest entry; that host then has to re-pair next time.

Limitations

These are constraints of the design, not bugs to be reported.

One active connection at a time

BLE peripherals advertise to many scanners but accept only **one active connection**. So while you can be paired with
PC + phone + laptop at once, only one of those can have an open session at any moment. The others can't connect until
the current one disconnects.

No virtual COM port on Windows

BLE NUS is a GATT profile, not Bluetooth Classic SPP. Windows does not auto-create a COM port for it, and no
terminal app talks BLE NUS natively. That's why the Python bridge exists -- it presents a TCP socket that Tera
Term/PuTTY can attach to.

If you really want a COMxx device for compatibility with other software, you'd need a virtual-COM driver like com0com
and a small custom helper. The bridge could be extended to drive com0com instead of (or in addition to) TCP. Not
included.

iOS pairing nuance

iOS will not allow BLE pairing without an active GATT operation following soon after. If you "pair" without then
connecting, iOS may silently un-pair. Always connect from an app right after pairing.

Reconnect delay

Rebooting the Pico (OPTION CPU_SPEED, watchdog reset, etc.) means ~10 seconds before the bridge reconnects.
Breakdown of where the time goes:
• Pico firmware boot + cyw43 BT firmware download: ~3-5 s
• HCI bring-up + first advertisement: ~1 s
• Host's BLE scan latency: ~2-5 s
• Bridge retry backoff: 1 s

Nothing to do about the Pico-side cost; the bridge could be extended to cache the BD_ADDR and reconnect by address
(skipping the scan) for ~3-5 s savings.
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Bond mismatch after firmware rebuild

A firmware build that bumps MagicKey triggers ResetOptions() on first boot, which zeroes Option.bt_tlv. The Pico
forgets its bonds but the host doesn't. Result on reconnect:
• Windows: characteristic reads return "Unreachable" until you
  Settings -> Remove device -> re-pair.
• Linux: "Authentication failed" -- fix is
  bluetoothctl remove <MAC> then re-pair.
• Phone: Forget the device in Bluetooth settings, re-pair.

This only happens after MagicKey changes (i.e., development builds that change the Option layout). Stable releases
don't disturb existing bonds.

No persistence on PSRAM-only boards

The bond storage lives in the PicoMite Option flash sector. Boards where PicoMite runs from PSRAM still write Options
to flash, so this is not a real limitation -- mentioned only because it's a common question.

Throughput

RFCOMM-class throughput is not the goal -- this is a console link. Typical sustained throughput is ~5-20 KB/s
depending on the host's BLE stack and connection parameters. Fast enough for typing, listing programs, even
XMODEM transfers, but not for moving large binary files.

Range

Practical ranges to expect, governed by the CYW43439 radio (Class 2 BLE, ~+4 dBm TX, ~-93 dBm RX) and the small
PCB antenna on Pico 2 W:

Scenario Realistic range

Open air, line of sight 20-30 m

Same room with normal furniture 10-15 m

Through one interior wall (drywall) 5-10 m

Through two walls or one concrete wall 2-5 m, often unreliable

Between floors 3-7 m, marginal

Things that improve range:
• Class 1 USB Bluetooth dongle on the host (up to +20 dBm) -- adds
  several meters, especially through obstructions, because the better   receiver on the host side carries the weak Pico
transmissions.
• Line of sight. One drywall costs ~10 dB, two walls ~20 dB --
  that's most of the link budget. A hallway goes much further than   the same distance through walls.
• Antenna orientation. The PCB antenna has lobes; rotating the
  board 90° can rescue a borderline link. Standing up beats flat on a   desk.

Things that don't help much in practice:
• BLE 2M PHY (higher throughput, lower range -- we use 1M which is
  better balanced for this use).
• BLE Coded PHY (long-range Bluetooth 5) -- neither btstack here nor
  Windows BLE negotiate it readily for NUS; not configured.
• External antenna mod -- the antenna pad/disable resistor exists on
  Pico 2 W (like Pico W), but the mod is fiddly and only adds a few   dB.

In short: plenty of range for working at a desk, debugging from across the bench, or running BASIC from a phone in the
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same room -- but don't expect to control devices reliably from another floor of the building.

BLE only -- no Bluetooth Classic

The build links pico_btstack_ble, not pico_btstack_classic. There is no SPP, no audio (A2DP), no HID. Pure BLE GATT
for the NUS profile.

Console output buffering during pre-pairing

Anything PicoMite prints before a host has subscribed to TX notifications is buffered in a 1 KB ring on the device. If the
device prints more than 1 KB before you connect, the oldest bytes are dropped to make room for newer ones -- so the
most recent output (the prompt) is what reaches you when you finally connect.

Troubleshooting

"Could not start notify on 000A: Unreachable" (bleak / Windows)

The host has a cached LTK that doesn't match the Pico's. Remove the device from Windows Settings -> Bluetooth &
devices, then pair again.

Bridge keeps cycling connect/disconnect

Same root cause as above. Each cycle is the host attempting reconnect with a stale LTK. Re-pair fixes it.

"Authentication failed" (Linux)

bluetoothctl remove <PicoMAC> then re-pair (scan on, pair, trust).

"DBusError: Not authorized" (Linux)

User isn't in the bluetooth group. sudo usermod -aG bluetooth $USER then log out / back in.

Tera Term shows weird block characters / nothing

• Setup -> Terminal -> Local Edit Mode must be OFF.
• Service must be Telnet (the bridge sends IAC negotiation that
  Tera Term needs to switch to char-at-a-time mode).
• Local echo must be OFF (PicoMite echoes; turning local echo on
  doubles every keystroke).

Characters only echo when I press Enter

Tera Term Local Edit Mode is on. Turn it off; save setup.

Connecting from a fresh laptop, BLE LE Explorer shows the device

but characteristics are "Unreachable" The device needs to be paired through OS settings first. BLE Explorer itself cannot
drive pairing on Windows; it only browses. Pair via Settings -> Add device, then re-open Explorer.

Bridge prints "[BLE] not found, will retry"
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Pico may have rebooted; wait ~10 s. If it persists, check that the device is still advertising -- connect from a phone to
verify, or re-flash the firmware. Could also be Windows BLE permissions / adapter state: in Settings -> Bluetooth, toggle
Bluetooth off then on to reset the host stack.

"no such file or directory" from nmake in CMake build

Not BLE-related, but a common gotcha: Visual Studio's MSVC tools aren't on PATH. Launch VS Code from the
**Developer Command Prompt for VS**, or CMake: Select a Kit and choose the Visual Studio kit.

Files of interest in this build

File Purpose

BTConsole.c / BTConsole.h BLE NUS server, TX/RX rings, GATT/SM hooks

nus_gatt.gatt GATT database (NUS UUIDs, characteristics, flags); compiled to

nus_gatt.h by btstack's compile_gatt.py

btstack_config.h btstack feature flags; controls bonding, encryption, max peer

count

ble_bridge.py Cross-platform BLE NUS -> TCP forwarder for desktop terminal

use

FileIO.h Defines Option.bt_tlv[2048] for persistent bond storage

configuration.h PICOMITEBT block: flash offsets, magic key, heap sizes

CMakeLists.txt PICOBTRP2350 variant definition; links pico_btstack_ble,

pico_btstack_cyw43, pico_cyw43_arch_none
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