Home
JAQForum Ver 24.01
Log In or Join  
Active Topics
Local Time 21:28 13 Jul 2024 Privacy Policy
Jump to

Notice. New forum software under development. It's going to miss a few functions and look a bit ugly for a while, but I'm working on it full time now as the old forum was too unstable. Couple days, all good. If you notice any issues, please contact me.

Forum Index : Site News : Forum upgrade

     Page 3 of 15    
Author Message
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 10:34pm 31 Jul 2019
Copy link to clipboard 
Print this post

Thanks Ben,

I'll add a donate button in a few weeks once I'm happy with the new forum. I'll chat later about your sister and Quicken.

  mackoffgrid said  Hi Glen

Another bug? you may want to look at.

Sometimes when you click on the last page button it goes to an empty page.
For example, look at example Click on Goto last page and you'll see what I mean - if you can catch it before someone adds a reply, like me

The current last post is 0704 20190818 Brisbane time.

Cheers
Andrew


Yep, see that. Thanks

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
panky

Guru

Joined: 02/10/2012
Location: Australia
Posts: 1100
Posted: 11:56am 01 Aug 2019
Copy link to clipboard 
Print this post

Hi Glen,

Any thoughts on the Print Thread option that we used to have?

panky
... almost all of the Maximites, the MicromMites, the MM Extremes, the ArmMites, the PicoMite and loving it!
 
robert.rozee
Guru

Joined: 31/12/2012
Location: New Zealand
Posts: 2303
Posted: 12:10pm 01 Aug 2019
Copy link to clipboard 
Print this post

hi glenn,
looks like 'sticky' topics also appear in the list of 'normal' topics. see the 'photos' thread in the 'Microcontroller and PC projects' forum. is this intended?

also, when viewing this thread ('Forum upgrade') starting from the 'Microcontroller and PC projects' forum, page 2 onwards skips over to the 'Site News' forum.


cheers,
rob :-)
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 10:49pm 01 Aug 2019
Copy link to clipboard 
Print this post

Thanks everyone for posting these issues. I'm working through them. Some are proving pesky, like members getting bumped to Admin group when they post, and others, like print friendly pages, will have to wait while I get the major issues sorted.

Keep them coming.

But the new forum is definitely faster and more reliable, and I havent even looked at optimising the code or database yet.

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
disco4now

Guru

Joined: 18/12/2014
Location: Australia
Posts: 864
Posted: 04:50am 02 Aug 2019
Copy link to clipboard 
Print this post

When using "Bookmark this page" in firefox, the suggested title for the bookmarking of the current page seems to be stuck as "TheBackShed.com - Homegrown Power", before it would use the current topic.

regards
Gerry
Latest F4 Latest H7
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 05:22am 02 Aug 2019
Copy link to clipboard 
Print this post

Ran some code to re-import the old forum posts. This should have fixed up those posts where most of the post was missing.

There are still two posts that didnt get imported, these were massive! When I created the new forum database I used a field type of TEXT, which has a limit of 65,535 characters, but these 2 posts were like over 90,000 characters long.

So tonight I'll do a extra database backup, change that field type to MEDIUMTEXT, which will handle 16,777,215 characters, and then re-import those 2 posts.

Makes you wonder, how may times would you press a keyboard key in a life time?

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
KeepIS

Guru

Joined: 13/10/2014
Location: Australia
Posts: 1522
Posted: 05:34am 02 Aug 2019
Copy link to clipboard 
Print this post

Just a quick thank you for all the work you are doing, as others have noted, the speed and stability of the Forum is evident even in these early stages of the changeover.

Mike.
It's all too hard.
Mike.
 
renewableMark

Guru

Joined: 09/12/2017
Location: Australia
Posts: 1678
Posted: 07:30am 02 Aug 2019
Copy link to clipboard 
Print this post

No hurry, but a edit button would be good to fix my spelling stuff ups
Cheers Caveman Mark
Off grid eastern Melb
 
Chopperp

Guru

Joined: 03/01/2018
Location: Australia
Posts: 1039
Posted: 07:38am 02 Aug 2019
Copy link to clipboard 
Print this post


...Note to self. Copy message before changing the font...

Glenn, I noticed that my "Review Post" just displays everything as one paragraph.

Regards a mobile friendly version, I would like to see an option for bigger fonts, even for the PC version.

Keep up the good work. I for one really have little idea as to what is involved in doing what you are doing.
ChopperP
 
paceman
Guru

Joined: 07/10/2011
Location: Australia
Posts: 1329
Posted: 10:18am 03 Aug 2019
Copy link to clipboard 
Print this post

Yes, same issue as Chopper with all formatting removed on the "Preview Post" - i.e. one big paragraph. That was on the 31st when I posted here. Win7/64 and Firefox.

Just checked it again and same thing.

Greg
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 11:47pm 03 Aug 2019
Copy link to clipboard 
Print this post

Preview Post should be working now.
The Edit button is back, tread carefully, probably a bug or several.
The last page blank bug should be fixed.
The time zones forgetting my setting bug fixed.

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
Chopperp

Guru

Joined: 03/01/2018
Location: Australia
Posts: 1039
Posted: 12:05am 04 Aug 2019
Copy link to clipboard 
Print this post

Yep Edit seems to work.

As does formatting for Preview Post

Thanks Glenn

Edit. When you do edit a post, the original posting time seems to remain the same (as it originally did).

Any chance or updating the post time with the edit?
Edited 2019-08-04 10:08 by Chopperp
ChopperP
 
bigmik

Guru

Joined: 20/06/2011
Location: Australia
Posts: 2901
Posted: 10:30pm 04 Aug 2019
Copy link to clipboard 
Print this post

G’day Glenn,

In the list of threads the envelope with the star that indicates new messages doesn’t seem to always (if ever) update..

Regards,

Mick

Ps. Keep up the good work and I second a donate button

Mik
Mick's uMite Stuff can be found >>> HERE (Kindly hosted by Dontronics) <<<
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 11:51pm 04 Aug 2019
Copy link to clipboard 
Print this post

  Chopperp said  
When you do edit a post, the original posting time seems to remain the same (as it originally did).

Any chance or updating the post time with the edit?


I had a think about this. Decided to leave it as it is for the sake of the paper trail. Any edits are date stamped, so we have both the date the posts was first saved, and the date it was edited.

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 12:09am 05 Aug 2019
Copy link to clipboard 
Print this post

I've just uploaded a change where when you post a new or edit a post, it should take you back to that post ( or end of the thread ) when you save. Also the notification email link should do the same.

If after a post or edit, you end up somewhere weird, let me know.

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
Chopperp

Guru

Joined: 03/01/2018
Location: Australia
Posts: 1039
Posted: 01:48am 05 Aug 2019
Copy link to clipboard 
Print this post

Ok re Post Times.

Just managed to do a double post. Couldn't do that before. Took a bit long to respond so I clicked Save Post again
ChopperP
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 01:57am 05 Aug 2019
Copy link to clipboard 
Print this post

Yeah see that double post. Next time I'm logged into the server I'll remove it.

I'll add some code to acknowledge you pressed the Save button, so you dont think nothing has happened and you press it again.

When saving a post sometimes there is a delay as the forum code tries to connect to the email server to send the notifications. The email server is not on the same server, but there is a email server on that server that I may try to use.

Sending emails from code is a real prick at the moment, especially to anyone with a Microsoft account ( hotmail, live, outlook, office 365 ). Their anti span algorithms are overboard and lots of valid emails either end up in the junk folder or just get deleted. The Microsoft forums are full of people like me just trying to set up their code to send emails and Microsoft deny there is a problem, but its easy to prove there is.

Glenn
Edited 2019-08-05 11:59 by Gizmo
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
disco4now

Guru

Joined: 18/12/2014
Location: Australia
Posts: 864
Posted: 10:40am 05 Aug 2019
Copy link to clipboard 
Print this post

  disco4now said  When using "Bookmark this page" in firefox, the suggested title for the bookmarking of the current page seems to be stuck as "TheBackShed.com - Homegrown Power", before it would use the current topic.

regards
Gerry

Just in case you missed this one.Still seems to be there, maybe only firefox?
Latest F4 Latest H7
 
robert.rozee
Guru

Joined: 31/12/2012
Location: New Zealand
Posts: 2303
Posted: 11:53am 05 Aug 2019
Copy link to clipboard 
Print this post

hi Glenn,
it would be neat if there was a way to have images in threads appear as 320x200 pixel thumbnails that when clicked on open up as the full image (maybe even in a new tab). ideally, this could be something that can be set by the person reading the thread in "My Settings": display small images with link, display full image within thread.

i'm often reading the forums on a machine with a 1024x600 screen, so most images folks post in threads end up forcing a horizontal scroll bar.

also, i'm sure that in the old forums you could click straight into the last page of a multi-page thread.


cheers,
rob :-)
 
Gizmo

Admin Group

Joined: 05/06/2004
Location: Australia
Posts: 5049
Posted: 12:01pm 05 Aug 2019
Copy link to clipboard 
Print this post

  disco4now said  
  disco4now said  When using "Bookmark this page" in firefox, the suggested title for the bookmarking of the current page seems to be stuck as "TheBackShed.com - Homegrown Power", before it would use the current topic.

regards
Gerry

Just in case you missed this one.Still seems to be there, maybe only firefox?


Yeah I havnt missed anything, all the messages and posts about the forum upgrade are appreciated and all will be addressed in time. I still have a lot of area's that I haven't even started to develop yet ( Member avatar uploads, edit signatures, Member lists, etc, etc ) and want to get these done first.

Chopper I've lost that post of your's with the double post, could you point me in the right direction?

Glenn
The best time to plant a tree was twenty years ago, the second best time is right now.
JAQ
 
     Page 3 of 15    
Print this page
© JAQ Software 2024